System Requirements

Inspection Manager System Requirements

Running Inspection Manager requires that you use Google Chrome, Firefox, or Microsoft Edge as your internet browser.

Inspection Manager Mobile Requirements

When purchasing new devices, we recommend that you get the latest and greatest or the previous version of the latest devices available to ensure that your device is supported.

iPhone:

  • - Your device must be running iOS 9 or higher
    • - This is the minimum iOS version supported

Android:

  • - Supported Android devices must be running version 4.1 - 8.0
  • - Please note that devices using 4.1 and some 5.0 devices may not be able to handle Intuitive Inspections due to performance reasons